Corrupted links in emails

User avatar
dadamail
Site Admin
Posts: 18
Joined: Fri Nov 29, 2019 10:47 pm
Contact:

Re: Corrupted links in emails

Post by dadamail » Sun Oct 04, 2020 5:45 pm

So according to the RFC linked into one of the Stack Overflow q's:

https://tools.ietf.org/html/rfc5321#section-4.5.2

it's the SMTP client who's job it is to double up dots that start on a new line. In your sendmail command case, that would be the sendmail command, so that's where the problem would be. I think you agree with me on that. Your SMTP server does seem to do the right thing though, so it's just the sendmail command and how it interacts with your SMTP server.

I don't know if I'm willing to make a hack in Dada Mail to get around broken sendmail commands, as it doesn't seem to be universal. In fact, it may just be you having the problems - you may want to see if you can find more info on the type/version of your sendmail command - a simple,

Code: Select all

man sendmail
would suffice - who knows? Maybe there's a flag that changes how starting dots are handled?

Lots of reasons why I don't wanna handle this myself: the CPAN module that handles quoted-printable encoding is very very mature, and I don't think there's a bug in it (or at least this bug). There's also no way to tell it what characters to encode, so there's no way for me to tell it to encode dots. I don't ever directly interface with this module either - I interface with the MIME Entity module, which is also very mature, but does not have any options to handle dots that start a line.

For you, perhaps switch your encoding? Base64 would hide those dots for ya,
Justin J
Creator, Dada Mail

SIVC
Posts: 15
Joined: Thu May 14, 2020 11:06 am

Re: Corrupted links in emails

Post by SIVC » Mon Oct 05, 2020 10:55 pm

Thanks for reply and suggestions. I accept the issue may be with the sendmail implentation.
Sadly "man sendmail" just gave me "No manual entry for sendmail"
Given I'm using a shared hosting package, I'm not sure I'd be allowed to change anything anyway.
I also tried setting Base64 in "Sending->Advanced Options' but still got errors, but when I investigated I found it was still using Quoted-Printable. I'm wondering if Base64 requires CPAN Bundle::DadaMail to be installed? I had a go at installing that when I first used Dadamail, but it it didn't seem straight forward under my shared hosted scheme so I gave up - I'll have another go sometime.

But some good news - I've now got all my mailing lists running using SMTP rather than sendmail and that gives no errors in my testcases.

I find it puzzling I'm the only user finding this issue with sendmail, as Ionos are the 4th largest web hosting company in the world so I'd imagine you must have some other customers using them?

User avatar
dadamail
Site Admin
Posts: 18
Joined: Fri Nov 29, 2019 10:47 pm
Contact:

Re: Corrupted links in emails

Post by dadamail » Tue Oct 06, 2020 2:50 am

No - Base64 should be available without installing any extra modules - I'll look at that for you.

I'm just as surprised - this app has been around for 20+ years now, and this is the first time I've had to investigate this particular issue! Life for the app started with *only* supporting sendmail.

Glad SMTP is working though,
Justin J
Creator, Dada Mail

SIVC
Posts: 15
Joined: Thu May 14, 2020 11:06 am

Re: Corrupted links in emails

Post by SIVC » Thu Oct 08, 2020 12:49 pm

Yes, getting SMTP working effectively solved the problem we've being having at last - it's been a frustrating experience at times but I'm happy we've got a solid explanation of the root course so can be confident corrupted links won't re-occur if I use SMTP mode. Thanks for your help - I've certainly learnt a lot about sending emails along the way (e.g. previously I had no idea what Quoted-Printable was!).
FYI, in sendmail mode, saving output to a file by the config change you previously suggested, I also tried binary, 8bit & 7bit modes but they all came out as Quoted-Printable on my installation.

User avatar
dadamail
Site Admin
Posts: 18
Joined: Fri Nov 29, 2019 10:47 pm
Contact:

Re: Corrupted links in emails

Post by dadamail » Thu Oct 08, 2020 7:09 pm

SIVC wrote:
Thu Oct 08, 2020 12:49 pm
FYI, in sendmail mode, saving output to a file by the config change you previously suggested, I also tried binary, 8bit & 7bit modes but they all came out as Quoted-Printable on my installation.
Yeah, actually seems like a bug in Dada Mail, when you send a message via Bridge,
Justin J
Creator, Dada Mail

Post Reply